View Issue Details

IDProjectCategoryView StatusLast Update
0005963OXID eShop (all versions)5. ------ UpdateApp / Update ------public2014-11-28 08:32
Reportermartinwegele 
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.9.0 / 5.2.0 
Target Version4.9.3 / 5.2.3Fixed in Version4.9.0 / 5.2.0 
Summary0005963: UTF8-update script throws fatal error
DescriptionIf you try to switch the charsets and collations of the DB with OXID's update scripts according to the https://www.oxid-esales.com/en/support-services/documentation-and-help/oxid-eshop/installation/oxid-eshop-update-installation/update-eshop-to-utf-8-encoding.html you will get this error:
Fatal error: Call to undefined method oxConfig::getParameter() in update.php on line 81
Additional InformationThat's because getParameter was removed with 5.2.0 / 4.9.0: http://wiki.oxidforge.org/Tutorials/Removed_deprecated_source#Removed
It says: "Use public oxConfig::getRequestParameter()"
TagsUTF-8
ThemeAll
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005968 resolvedsaulius.stasiukaitis UTF8-update script throws fatal error (3) 
related to 0005966 resolvedsaulius.stasiukaitis UTF8-update script throws fatal error (2) 
related to 0005965 resolvedsaulius.stasiukaitis utf-8-update returns undefined var 
related to 0005970 resolvedsaulius.stasiukaitis UTF8-update script throws fatal error (5) 

Activities

There are no notes attached to this issue.