View Issue Details

IDProjectCategoryView StatusLast Update
0005945OXID eShop (all versions)5. ------ UpdateApp / Update ------public2014-12-02 12:56
Reportermichael_keiluweit 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionnot fixable 
Product Version4.7.11 / 5.0.11 
Target VersionFixed in Version 
Summary0005945: updateApp throws a notice message during executing [Note:][exec:] version: 5.0.12 action: updateSqlFromPHP
DescriptionWhile updating an EE 5.0.11 to 5.0.14 the following message will be displayed:


[email protected]:/var/www/supportvm53/OXID_ESHOP_EE_5.0.11_SNAPSHOT/updateApp# php run_cli.php
    [Note:][exec:] version: 5.0.12 action: updateSqlFromPHP

    Notice: Undefined property: object_ADOConnection::$fetchMode in /supportvm53/OXID_ESHOP_EE_5.0.11_SNAPSHOT/core/adodblite/adodbSQL_drivers/mysql/mysql_meta_module.inc on line 228


    Call Stack:
        0.0040 633240 1. {main}() /supportvm53/OXID_ESHOP_EE_5.0.11_SNAPSHOT/updateApp/run_cli.php:0
        0.3095 8347528 2. updateProcess->runStep() /supportvm53/OXID_ESHOP_EE_5.0.11_SNAPSHOT/updateApp/run_cli.php:26
        0.3398 8383840 3. updateBase->update() /supportvm53/OXID_ESHOP_EE_5.0.11_SNAPSHOT/updateApp/core/updateProcess.php:160
        0.3399 8384544 4. update_5_0_12->updateSqlFromPHP() /supportvm53/OXID_ESHOP_EE_5.0.11_SNAPSHOT/updateApp/core/updateBase.php:83
        0.3476 8573872 5. oxDbMetaDataHandler->fieldExists() /supportvm53/OXID_ESHOP_EE_5.0.11_SNAPSHOT/updateApp/updates/php/5.0.12.php:37
        0.3476 8573872 6. oxDbMetaDataHandler->getFields() /supportvm53/OXID_ESHOP_EE_5.0.11_SNAPSHOT/core/oxdbmetadatahandler.php:89
        0.3476 8574184 7. oxLegacyDb->metaColumns() /supportvm53/OXID_ESHOP_EE_5.0.11_SNAPSHOT/core/oxdbmetadatahandler.php:56
        0.3477 8574184 8. mysql_meta_ADOConnection->MetaColumns() /supportvm53/OXID_ESHOP_EE_5.0.11_SNAPSHOT/core/oxlegacydb.php:336


    -----
    [Note:][exec:] version: 5.0.12 action: updateSql

    -----
    [Note:][exec:] version: 5.0.12 action: updateMultilingualFields

    -----
    [Note:][exec:] version: 5.0.13 action: updateSqlFromPHP

    -----
    [Note:][exec:] version: 5.0.13 action: outputInformation
    [Note:]Default user groups accessibility via URL was turned off. If you want to enable them again, you must go to: Admin->Master sett ings->Core settings->System->Other settings and than remove from the prohibited user groups list.
     *> press enter to continue:




This line is the cause: if ($this->fetchMode !== false) $savem = $this->SetFetchMode(false); (\core\adodblite\adodbSQL_drivers\mysql\mysql_meta_module.inc).


Interestingly: All other places in this file with the variable $this->fetchMode are commented
Steps To Reproduce

  1. Check error reporting level. It should include notice mesages

  2. Install OXID_ESHOP_EE_5.0.11

  3. copy the patch from 5.0.11 to 5.0.14 into the root directy

  4. execute the patch via CLI

  5. Have a look into the log file, if it wasn't display in the terminal

Tags3rd Party Libraries, Update App
ThemeAzure
BrowserAll
PHP Versionany
Database Versionany

Relationships

related to 0005848 resolvedrobert blank OXID eShop (all versions) adodblite throws a strict error 
related to 0003850 resolvedtomas_liubinas OXID ERP Interface if PHP error reporting is on, wsdl file is broken 
related to 0000245 resolvedarvydas_vapsva OXID eShop (all versions) XML export does not work 

Activities

michael_keiluweit

2014-11-04 09:27

developer   ~0010308

It's obvious that this notice message is thrown in many updateApps which using a DB connection.

Linas Kukulskis

2014-12-02 12:56

reporter   ~0010369

it related with 3rd part library, and for oxid php notices should be switched off.