View Issue Details

IDProjectCategoryView StatusLast Update
0005942OXID eShop (all versions)2.6. Administer orderspublic2015-01-12 17:19
ReporterHenning Kockerbeck 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.9.0 / 5.2.0 
Target Version4.9.3 / 5.2.3Fixed in Version4.9.3 / 5.2.3 
Summary0005942: Delivery cost rule with 'size' break tab in order administration
DescriptionIf a delivery cost rule that deals with an articles size is in effect, one of the tabs in the order management is broken. Instead of showing basic information about the order, the "Stamm" tab (German localization) shows the shops start page.
Steps To Reproduce1.) Make sure that a delivery cost rule that deals with an articles size (in the condition) is in effect
2.) In the backend, navigate to list of orders
3.) Choose any order
4.) Try to switch to "Stamm" tab (second tab from the left)
Additional InformationRefer to http://forum.oxid-esales.com/showthread.php?p=151441#post151891 and following as well.

It looks like oxdelivery.php (line 246) tries to ask an object of class oxOrderArticle for the article's size, which oxOrderArticle does not know about. Instead, oxdelivery.php should probably get the oxOrderArticle's oxArticle and ask that about the size.
TagsNo tags attached.
ThemeAll
BrowserAll
PHP Versionany
MySQL Versionany

Activities

saulius.stasiukaitis

2015-01-07 12:21

reporter   ~0010591

Last edited: 2015-01-07 12:21

View 2 revisions

Check for object type added to oxDelivery::getDeliveryAmount

if ($oProduct->isOrderArticle()) {
    $oProduct = $oProduct->getArticle();
}

Same problem existed for weight and size.

martinwegele

2015-01-12 17:19

reporter   ~0010604

https://github.com/OXID-eSales/oxideshop_ce/commit/fbd824de2d2678326a2ca671e2bd9e7e3ceaba35