View Issue Details

IDProjectCategoryView StatusLast Update
0005932OXID eShop (all versions)4.12. Subshop handlingpublic2015-11-05 17:32
Reportermartinwegele 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version4.9.0 / 5.2.0 
Target Version4.9.6 / 5.2.6Fixed in Version 
Summary0005932: Impossible to change shop if mobile theme is active
DescriptionNot sure what this is or where it comes from:
If you create another shop in an EE and activate it without entering a specific shop URL you will normally get to the "shop selection page" if you call the domain.
However if the mobile theme switcher is active in the master (shop #1) but not in the newly created shop (shop #2) once you selected shop #2 you cannot access the shop selection page any more. Instead you will be redirected to: index.php?shp=2&cl=start&redirected=1 and there will be an exception in the log (s. private note)
If you deactivate the theme switcher you can access the page again. Very strange behaviour. I don't know if this is because of the mobile theme switcher module or the mall settings since I have not investigated deeper.
btw: Everything was done from a desktop PC so the mobile theme was never displayed, only Azure.
TagsMobile Theme, Subshops
ThemeAzure
BrowserAll
PHP VersionNot defined
MySQL VersionNot defined

Activities

martinwegele

2014-12-02 10:37

reporter   ~0010366

Last edited: 2014-12-02 10:37

View 2 revisions

Maybe related to 0005346? It seems that this changed the behaviour of the shop so the shop-id from admin session and sid are somehow connected. (just a wild guess)

jurate.baseviciene

2014-12-02 13:17

reporter   ~0010370

Last edited: 2015-01-05 12:18

View 2 revisions

Hi,

Steps to reproduce:

1. In the same browser open admin and frontend pages;
2. Login to admin https://demoshop.oxid-esales.com/EnEd/admin
3. Activate mobile theme in the master shop;
4. Create new shop2 and activate created shop2;
5. Go to frontend
6. Open shop2-> http://demoshop.oxid-esales.com/EnEd/startseite/?shp=2
then open http://demoshop.oxid-esales.com/EnEd/ then you will be redirected to
http://demoshop.oxid-esales.com/EnEd/index.php?shp=2&cl=start&redirected=1 and you will not be able work with frontend while you will not delete sid coocies.

HR

2015-07-21 09:52

manager   ~0011118

If your shop does not use OXID's ERP interface, the workaround is to set request_order = "GP" in php.ini. In case ERP is installed together with the mobile theme, the current workaround would be either to not use the Mallstartpage or to activate the mobile theme in all subshops.