View Issue Details

IDProjectCategoryView StatusLast Update
0005876OXID eShop (all versions)6. ------ Setup -------public2014-09-11 11:01
Reportermartinwegele 
PriorityurgentSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.9.0_5.2.0_beta1 
Target Version4.9.0_5.2.0_RC1Fixed in Version4.9.0_5.2.0_RC1 
Summary0005876: PHP5.2 is not officially supported any more
DescriptionAccording to this http://blog.oxid-esales.com/2013/10/php-52-will-not-be-supported-from-oxid-eshop-versions-48-and-51-on/ the shop is neither tested nor distributed for PHP5.2 any more. The system requirements check (used both in admin panel and setup process) should be adjusted accordingly.
Currently it checks for "PHP version at least 5.2.10" but it should be "PHP 5.3.25 or above" according to the official page: https://www.oxid-esales.com/en/products/facts/oxid-eshop-enterprise-edition/system-requirements.html
https://www.oxid-esales.com/en/products/facts/oxid-eshop-community-edition/system-requirements.html
Additional InformationMust be changed in oxSysRequirements::checkPhpVersion(): https://github.com/OXID-eSales/oxideshop_ce/blob/v4.9.0_beta1/source/core/oxsysrequirements.php#L617
TagsPHP, Setup
ThemeAll
BrowserAll
PHP Versionany
MySQL Versionany

Activities

martinwegele

2014-09-10 17:28

reporter   ~0010140

"Zend Optimizer or Zend Guard Loader installed" should be corrected, too.
For PHP5.3 and 5.4 it is called Zend Guard Loader.

mantas.vaitkunas

2014-09-11 11:01

administrator   ~0010145

Last edited: 2014-09-11 11:02

View 2 revisions

Changed required version and translations for Zend guard loader.