View Issue Details

IDProjectCategoryView StatusLast Update
0005861module PayPalmodule PayPal - subpublic2014-09-11 11:49
Reporterbugposter 
PriorityhighSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.1.1 
Target Version3.1.2Fixed in Version3.1.2 
Summary0005861: No redirect to paypal from step 3 to 4 in mobile template
DescriptionDisable the following options in the paypal module:
- Warenkorb bei PayPal anzeigen
- Voreingestellte Kundenzustimmung
After that, try to buy in mobile template. No redirection from step 3 to step 4.
Additional InformationAlso, the redirection does not work if only "Voreingestellte Kundenzustimmung" option is enabled.
So, 2 situations that do not work correctly in mobile theme, but works in azure:
1. when both (above listed) options are disabled
2. when only "Voreingestellte Kundenzustimmung" is enabled
TagsMobile Theme, Redirect

Activities

bugposter

2014-09-01 09:48

reporter   ~0010118

In our shop 4.8.1 CE it does work when only the option "Warenkorb bei PayPal anzeigen" is activated and "Voreingestellte Kundenzustimmung" is disabled. After that we set checkbox for customer agreement via css to "display: none" - so this is our bugfix for now.

aurimas.gladutis

2014-09-11 11:49

reporter   ~0010147

Last edited: 2014-09-11 11:49

View 2 revisions

The problem was in views/blocks/mobile/oepaypalpaymentselector.tpl file. This file should look like this:
[{if $oViewConf->oePayPalIsModuleActive('oethemeswitcher', '1.1') && $sPaymentID == "oxidpaypal" }]
    [{if $oViewConf->isStandardCheckoutEnabled()}]
    [{oxstyle include=$oViewConf->getModuleUrl('oepaypal','out/mobile/src/css/paypal_mobile.css')}]

    <div id="paymentOption_[{$sPaymentID}]" class="payment-option [{if $oView->getCheckedPaymentId() == $paymentmethod->oxpayments__oxid->value}]active-payment[{/if}]">
        <input id="payment_[{$sPaymentID}]" type="radio" name="paymentid" value="[{$sPaymentID}]" />
        <div class="paypalDescBox">
            <a href="#"><img class="paypalPaymentImg" src="[{$oViewConf->getModuleUrl('oepaypal','out/mobile/src/img/')}]paypal-medium.png" border="0" alt="[{oxmultilang ident="OEPAYPAL_PAYMENT_HELP_LINK_TEXT"}]"></a>
            #

            [{assign var="paypalHelpLink" value="OEPAYPAL_PAYMENT_HELP_LINK"|oxmultilangassign}]
            [{oxscript add="$('.paypalPaymentImg, .paypalHelpIcon').click(function (){window.open('`$paypalHelpLink`','olcwhatispaypal','toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=yes, resizable=yes, width=500, height=450');return false;});"}]

            [{if $paymentmethod->oxpayments__oxlongdesc|trim}]
            <div class="paypalPaymentDesc">
                [{ $paymentmethod->oxpayments__oxlongdesc->getRawValue()}]
            </div>
            [{/if}]
        </div>

        [{if $oViewConf->sendOrderInfoToPayPal()}]
            <p class="paypalExpressCheckoutMsg">
                <input type="checkbox" id="displayCartInPayPal" name="displayCartInPayPal" value="1" [{if $oViewConf->sendOrderInfoToPayPalDefault()}]checked[{/if}]>
                <label for="displayCartInPayPal">[{oxmultilang ident="OEPAYPAL_DISPLAY_BASKET_IN_PAYPAL"}]</label>
            


        [{/if}]
    </div>
    [{/if}]
[{else}]
    [{ $smarty.block.parent }]
[{/if}]

The <input id="payment_[{$sPaymentID}]" type="radio" name="paymentid" value="[{$sPaymentID}]" /> was added so that correct payment method would be selected and
        [{if $oViewConf->sendOrderInfoToPayPal()}]
            <p class="paypalExpressCheckoutMsg">
                <input type="checkbox" id="displayCartInPayPal" name="displayCartInPayPal" value="1" [{if $oViewConf->sendOrderInfoToPayPalDefault()}]checked[{/if}]>
                <label for="displayCartInPayPal">[{oxmultilang ident="OEPAYPAL_DISPLAY_BASKET_IN_PAYPAL"}]</label>
            


        [{/if}]
was changed so that those checkboxes would work correctly.