View Issue Details

IDProjectCategoryView StatusLast Update
0005801OXID eShop (all versions)4.01. Database handlingpublic2014-06-26 16:02
Reporterddonatas 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.4 / 5.1.4 
Target VersionFixed in Version4.8.7 / 5.1.7 
Summary0005801: Don't work oxDbMetaDataHandler class method updateViews when want update specific tables
DescriptionCode:

        $oMetaData = oxNew('oxDbMetaDataHandler');
        $oMetaData->updateViews(array('some_db_table'));

doesn't creates/updates db table view, because oxDbMetaDataHandler::updateViews( $aTables = null ) calls

$oShop = oxNew( 'oxshop' );
$oShop->generateViews( $blMultishopInherit, $aMallInherit )

and methode oxShop::generateViews( $blMultishopInheritCategories = false, $aMallInherit = null )

doesn't use the passed parameters in own code




TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Activities

Linas Kukulskis

2014-06-26 16:01

reporter   ~0009987

fixed function's API documentation: doc comment