View Issue Details

IDProjectCategoryView StatusLast Update
0005787OXID eShop (all versions)1.04. Content, static (register, contact etc.) pagespublic2014-06-06 10:36
Reportermartinwegele 
PrioritylowSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.6 / 5.1.6 
Target VersionFixed in Version4.8.7 / 5.1.7 
Summary0005787: link to pdf file does not work if shop is installed in subdirectory
DescriptionOn the CMS page "withdrawal" there is a new link to the PDF file that contains the withdrawal form. Since the URL is relative to the domain it will not work if the shop resides in a subdirectory, e.g. "http://mydomain.com/shop".
https://github.com/OXID-eSales/oxideshop_ce/blob/v4.8.6/source/setup/sql/database.sql#L707
Remember that this must be corrected for both German and English CMS-texts!
Steps To ReproduceInstall a shop in a subdirectory of a domain, e.g. on your VM http://testshop/version4.8.6/
Access the page http://testshop/version4.8.6/en/Right-of-Withdrawal/ and click on the link to the PDF file.
Additional InformationThis can be corrected pretty easily if you just edit the link with the wysiwyg editor in the admin panel.
TagsNo tags attached.
ThemeAll
BrowserAll
PHP Versionany
MySQL Versionany

Activities

aurimas.gladutis

2014-06-06 10:36

reporter   ~0009944

the url should look like this:
[{$oViewConf->getBaseDir()}]out/pictures/wysiwigpro/Model_form_for_withdrawal_en.pdf
[{$oViewConf->getBaseDir()}]out/pictures/wysiwigpro/Model_form_for_withdrawal_de.pdf