View Issue Details

IDProjectCategoryView StatusLast Update
0005771OXID eShop (all versions)1.03. Basket, checkout processpublic2016-03-23 10:42
Reporterkrishnakumar 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.1 / 5.1.1 
Target VersionFixed in Version4.8.11 / 5.1.11 
Summary0005771: Previous users cart details are shown to another user
DescriptionWhen a user logs in and add certain things in his cart and then logs out -- and then another user uses the same computer and same browser and logs in - the cart details of the previous user is shown. Could you please clarify this bug.
Steps To ReproduceLogin -
Add to cart -
Logout -
In the same system in the same browser log in as another user -
The previous cart informations are shown
TagsSession
ThemeAzure
BrowserAll
PHP Version5.5
MySQL Version5.6

Relationships

related to 0002260 assignedflorian.auer Previously saved order should be merged with the newly started order with special logic 
has duplicate 0006268 closedflorian.auer Basket of last user is recoverable if the browser session hasn't changed 

Activities

FibreFoX

2014-05-22 14:59

reporter   ~0009921

i think its more a feature than a bug (and solvable with a small module)

krishnakumar

2014-05-26 08:55

reporter   ~0009923

But How come it can be considered as a "feature".. It could be a good feature if only one user is using the system/browser....But we cannot avoid the situation of using the same system by many. A feature is called a "feature" if it really helps all the users. Now its very confusing and has no sense.

Would like to get the confirmation on this issue soon on.

jurate.baseviciene

2014-06-19 15:24

reporter   ~0009983

Hi,

This bug is confirmed, because we have missing documentation.

krishnakumar

2014-08-25 08:06

reporter   ~0010088

Hello.... Would you please give a clarification on this issue. What is that missing here.