View Issue Details

IDProjectCategoryView StatusLast Update
0005761OXID eShop (all versions)4.08. Cachepublic2014-06-27 14:32
Reportermartinwegele 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.5 / 5.1.5 
Target VersionFixed in Version4.8.7 / 5.1.7 
Summary0005761: iDefaultCacheTTL is not respected
DescriptionIn the file cache all objects have a TTL of five years, while in memcached all objects will live forever, regardless of what value you set for the config option 'iDefaultCacheTTL' if you do not explicitly set a TTL for that object when calling oxCacheBackend::set() (third parameter).
This is not an issue as long as you only use the shop framework's models to manipulate data since they will always trigger the method executeDependencyEvent() which will invalidate the correct cache objects.
TagsNo tags attached.
ThemeAll
BrowserAll
PHP Versionany
MySQL Versionany

Activities

Linas Kukulskis

2014-06-27 14:32

reporter   ~0009989

fixed default parameter