View Issue Details

IDProjectCategoryView StatusLast Update
0005680OXID eShop (all versions)6. ------ Setup -------public2023-11-24 14:15
Reportermartinwegele 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.3 / 5.1.3 
Target VersionFixed in Version6.0.0-beta.1 
Summary0005680: Setup with oxSetupAps::install does not set language
DescriptionIf I saw it correctly there is one parameter missing in the array that is passed to other methods like saveDynPagesSettings():
        $aParams["sShopLang"] = $oUtils->getEnvVar( "SETTINGS_location_lang" );
Additional InformationMaybe it is worth to refactor the whole file since it is quite difficult to understand what is actually happening (when/where) in the setup process.
TagsNo tags attached.
ThemeNot defined
BrowserAll
PHP VersionNot defined
Database VersionNot defined

Activities

svetlana

2014-03-13 16:40

reporter   ~0009649

Probably fix should be:
$aParams["sShopLang"] = $oUtils->getEnvVar( "sShopLang" );
Because setup language not always should be same as shop language.

Sven Brunk

2023-11-24 14:15

administrator   ~0015940

Current implementation:
$sShopLang = isset($aParams["sShopLang"]) ? $aParams["sShopLang"] : $oSession->getSessionParam('sShopLang');