View Issue Details

IDProjectCategoryView StatusLast Update
0005658OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2015-06-22 11:42
Reportertorsten.dix 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version4.8.3 / 5.1.3 
Target VersionFixed in Version 
Summary0005658: Extremely slow oxarticle:save()
DescriptionIn oxcategory.php lines 365ff. we have found new code, which purges all articles which are in all categories which have the same category as the saved article.

In out shop setup this means, that all articles are purged, when we save one single article, because all articles are in the same main category.

Effect of this is, that the oxarticle::save is very slow (about 10 seconds per article) and that many purges are done, which slow down our severs.
TagsVarnish
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Relationships

related to 0006133 acknowledgedflorian.auer Editing articles very slow when reverse proxy is active 

Activities

mark

2014-02-18 19:27

reporter   ~0009520

Second thing is that each page is purged in a single request (like /yourcategory/, /yourcategory/1/, /yourcategory/2/).

Why not just purge /yourcategory/.* ?

tadas

2014-02-21 13:49

reporter   ~0009582

When article was saved each category it belonged to, it was flushed. Each category in turn would flush all it's articles. This might be the reason of slow article save process time.

We have made a change to category flushing, so it would no longer flush its articles subsequently when article is updated.

svetlana

2014-03-21 15:42

reporter   ~0009675

Reminder sent to: torsten.dix

Hi,
Thank you so much for submitting this issue, unfortunately but we can not reproduce it. Could you please send us more detailed information about how you reproduce it?