View Issue Details

IDProjectCategoryView StatusLast Update
0005643OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2014-03-06 12:37
Reportersirius205 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.3 / 5.1.3 
Target Version4.8.5 / 5.1.5Fixed in Version4.9.0_5.2.0_beta1 
Summary0005643: discount can not be deactivated after first activation
DescriptionWhen creating a discount (pro or abs) and activating it with a valid start and end date (current date has to be in that range) the discount is applied to the price calculation.
However, when deactivating the discount (not changing the date range) the prices wont recalculate but still use the discount.
Steps To Reproduce1.) Create new discount (Shop Settings -> Discounts -> Create new Discount) and enter a name for it
2.) Set Active checkbox AND fill in a valid start and end date (start date earlier than the current date, end date later) AND type in a discount (% / abs)
3.) Everything works as expected until here
4.) Now deactivate the discount without changing any other settings
TagsDiscount
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

aurimas.gladutis

2014-03-06 12:37

reporter   ~0009611

Hi, this behaviour is intended and is used for news, deliveries, promotions, etc. as well where item can be activated by date.

When "Active" checkbox is checked, we do not care any more about the date - it will be always active.
When this checkbox is not checked - whether this item is active will be decided by entered date (see the text near activation box "Active OR Active from __ to __").

These translations have been changed to "Always active" and "Active by date" to minimize confusion.