View Issue Details

IDProjectCategoryView StatusLast Update
0005631OXID eShop (all versions)4.02. Session handlingpublic2015-10-26 14:26
ReporterAdrian.Kirchner 
PriorityurgentSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.1 / 5.1.1 
Target Version4.8.6 / 5.1.6Fixed in Version4.8.6 / 5.1.6 
Summary0005631: Category default sorting leads to empty category lists when switching languages
DescriptionDue to the fact, that the category default sorting column (including lang dependent oxarticle-Viewname) is stored in the users session (if one is present) the generated oxArticleList select statement references an unknown column, therefore leads to an sql error which results in an empty category list.
Steps To Reproduce1) Setup a fresh EE 5.1.1 with demo data
2) set default sorting for category "Kiteboarding > Kiteboards" to eg. oxprice and descending
3) Visit shop frontend
4) Login
5) Visit category "Kiteboarding > Kiteboards"
6) click at the first product (Kiteboard Flyboards Flywave 2010)
7) switch the frontend language (eg. from german to english)
8) go back to the category "Kiteboarding > Kiteboards" via category navigator on the left

=> category list is empty because sessions stores the following order column: oxv_oxarticles_1_de.oxprice which is not present when selecting against oxview oxv_oxarticles_1_en
TagsCategory, Sorting
ThemeAzure
BrowserFireFox, Google Chrome, Opera
PHP Version5.3
MySQL Version5.5

Relationships

related to 0005241 assignedflorian.auer Sorting is saved to session—which is not nice. 

Activities

jurate.baseviciene

2014-01-31 14:20

reporter  

2014-01-31_1519.png (40,962 bytes)
2014-01-31_1519.png (40,962 bytes)

Linas Kukulskis

2014-04-18 16:13

reporter   ~0009849

removed views name from sorting sql snippet

QA

2015-10-26 14:26

administrator   ~0011282

https://github.com/OXID-eSales/oxideshop_ce/commit/b896b1c491b8c94039be5a588ceec417041b65f0