View Issue Details

IDProjectCategoryView StatusLast Update
0005617OXID eShop (all versions)2.8. Servicepublic2014-07-30 16:38
Reportermpienkny 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.1 / 5.1.1 
Target Version4.8.8 / 5.1.8Fixed in Version4.8.8 / 5.1.8 
Summary0005617: Failure in diagnostics
DescriptionWhen diagnostics ran, there is a failure reported:

Warning: mysql_get_server_info(): Access denied for user 'www-data'@'localhost' (using password: NO) in /var/www/../application/models/oxdiagnostics.php on line 518
Warning: mysql_get_server_info(): A link to the server could not be established in /var/www/../application/models/oxdiagnostics.php on line 518
Steps To ReproduceReduce database access to only known users with passwords (like it is in most productive environment)
Additional InformationFailure may a result because of function call of mysql_get_server_info() without any database resource.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005638 acknowledged Setup uses mysql_ functions only 

Activities

jurate.baseviciene

2014-01-28 16:00

reporter   ~0009449

Reminder sent to: mpienkny

Hi,

Sorry we can't reproduce the issue. Could you please check if you have mySql connection, are mySql credentials correct in config.inc.php?
What driver do you use - mysql or mysqli ?
Please give more details about your production environment (versions, configurations)?

Best regards,


 

mpienkny

2014-01-28 17:30

reporter   ~0009451

Hi,

thanks for looking. I tested now diffent machines - the first still sends the warning, the second suppresses the warning (maybe there is no php_admin_value set for error_reporting). But in both cases the function "oxDiagnostics::_getMySqlServerInfo()" return false, because there is no connection.
Could you confirm this?

Kind regards

Linas Kukulskis

2014-07-30 16:38

reporter   ~0010054

replaced with mysql guery