View Issue Details

IDProjectCategoryView StatusLast Update
0005616OXID eShop (all versions)5. ------ UpdateApp / Update ------public2019-09-11 14:23
Reporterleofonic 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version4.8.1 / 5.1.1 
Target VersionFixed in Version 
Summary0005616: invoicepdf does not work after update
DescriptionIf you follow the update instructions from 4.7 invoicepdf does not work because the former module directory modules/invoice.pdf still exists.
Steps To ReproduceInstall CE/PE 4.7.0 or later.
Make an order.
Update to 4.8.0 o later.
Go to admin and generate invoice pdf.
Additional InformationThe problem is, that after update modules in 5.1/4.8 shops are in "modules/oe/invoicepdf" directory, and updateApp doesn't delete old modules from modules directory.
TagsDocumentation, Solution Provided
ThemeNot defined
BrowserAll
PHP VersionNot defined
MySQL VersionNot defined

Activities

svetlana

2014-06-19 14:25

reporter   ~0009980

Last edited: 2014-06-19 14:26

View 2 revisions

After shop update need:
1. From modules dir delete invoicepdf dir
2. In Admin/Extension/Modules press on Invoice PDF module, which says:
"There are modules which are registered in eShop, but module directory is missing.
Do you want to remove all module information including config options and block information for templates?
    oxorder=>invoicepdf/myorder "
Select "Yes"
3. Activate Invoice PDF module

After these steps module will work properly.

Online documentation will be updated also

juergen_busch

2019-09-11 14:03

developer   ~0012995

Added hint about problem with invoicepdf module: https://docs.oxid-esales.com/eshop/de/5.3/installation/update-installation/update-ausfuehren.html.

Bug can be closed now. Sorry for being so late :-(