View Issue Details

IDProjectCategoryView StatusLast Update
0005598OXID eShop (all versions)5. ------ UpdateApp / Update ------public2014-03-14 17:40
Reportermartinwegele 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version4.8.1 / 5.1.1 
Target VersionFixed in Version 
Summary0005598: Wrong revision number in cups
DescriptionIt seems that the packaging mechanism uses the wrong "revision number" (I don't know what it's called for Git) for the cumulative update packages. So far I have seen this in the package UPDATE_OXID_ESHOP_CE_V.4.7.9_TO_V.4.8.1.zip in the two files pkg.rev and pkg.info. Since the oxchkversion mechanism uses these to verify the correct version of the shop it will always say "OXID eShop 4.8.1 in Revision 8197362f78e1795c922db58c554967a083f69d79 does not exist." in this shop. Other than that I do not know of any problems this might cause but maybe I am wrong?
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

martinwegele

2014-01-09 14:17

reporter   ~0009397

Last edited: 2014-01-13 10:00

View 3 revisions

So far I could only verify this for the 5.1.1 / 4.8.1 cups.
Please check if other cups are affected or if the generator is broken somehow so future releases will not be affected.

martinwegele

2014-01-09 17:01

reporter   ~0009402

Last edited: 2014-01-09 17:03

View 2 revisions

Same problem in EE cups:
[Package info]
revision = "8197362f78e1795c922db58c554967a083f69d79"
edition = "EE"
version = "5.1.1"
timestamp = "2013-11-19 14:05:26"

revision (= commit hash?) of full install packages is 0206915d3213c463d4310799020260fdba798fc1

andrius.silgalis

2014-01-13 13:51

reporter   ~0009411

No functionality relies on revision number in pkg.info and pkg.rev so no harm is done.

martinwegele

2014-03-14 17:40

reporter   ~0009654

This is a problem for the 4.6.8 packages and the reason why they cannot be checked by oxchkversion currently.