View Issue Details

IDProjectCategoryView StatusLast Update
0005576OXID eShop (all versions)4.11. Image handlingpublic2014-01-15 10:53
ReporterMitmacher 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.1 / 5.1.1 
Target Version4.7.11 / 5.0.11Fixed in Version4.7.11 / 5.0.11 
Summary0005576: Generated GIFs results in poor quality when being resized
DescriptionAccidently I found a problem in function resizeGif (oxpicgenerator.php) because I tried to use this generator outside OXID... ;-)
I wondered why the resized GIFs had such a poor quality in comparison with e.g. ImageMagick. So I digged a little inside the PHP documentation and came up with this:
Simply replace line 168:
$hDestinationImage = imagecreate( $iNewWidth, $iNewHeight );

with this one (similar to jpg/png creation):
$hDestinationImage = $iGdVer == 1 ? imagecreate( $iNewWidth, $iNewHeight ) : imagecreatetruecolor( $iNewWidth, $iNewHeight );

and all generated GIFs will look much better (especially small ones)! :-)
Steps To Reproduceself explaining I hope
TagsNo tags attached.
ThemeAzure, Basic
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0003194 resolvedIgor Iegupov transparent gif looses transparency when generated to different size 

Activities

jurate.baseviciene

2014-01-06 08:42

reporter   ~0009376

Reminder sent to: Mitmacher

Hi,

 As we saw, you already submitted a complete solution for this issue. If you feel fancy, you'd also have the possibility to contribute your changes directly to our GitHub repository on https://github.com/OXID-eSales/oxideshop_ce/. [^] [^] Please leave a note there with the bug number you fixed so we can close this issue in the bug tracker."

Best regards

Mitmacher

2014-01-06 21:08

reporter   ~0009381

Hi,
okay, today I gave github a first try but I got stuck on several questions (I used to work with svn only). I guess this is not the right place to ask for help, so by now I am not able to commit my patch into Github, sorry! ;-)
(indeed I've commited it, but only in the 4.6-branch of my OXID-fork and now I don't get any further)
But who could tell me in short, If I need a client for this, if I really need a new branch for such little changes, where do I have to put this bug number (short, or long desc and which format) and so on...?

Mitmacher

2014-01-07 22:02

reporter   ~0009388

Okay, in general I may have understood the github workflow now (I hope). :-)
So I've committed my bugfix into "Wendnet:b-5.1-ce" and created a pull request. That seems to be all I can do about it?
And who decides whether to also merge this commit into b-5.0-ce or b-4.6-ce? Or is it my job too to create 2 further commits (and pull requests) for those branches?

svetlana

2014-01-08 14:47

reporter   ~0009393

Reminder sent to: Mitmacher

Hi, Thanks a lot for contribution you made. You do not need to worry about merging your commit and no additional pull request are needed.

Linas Kukulskis

2014-01-14 10:50

reporter   ~0009414

resolved with contribution: https://github.com/OXID-eSales/oxideshop_ce/pull/88

martinwegele

2014-01-14 12:51

reporter   ~0009415

Maybe this contribution also fixes 0003194?