View Issue Details

IDProjectCategoryView StatusLast Update
0005558OXID eShop (all versions)2.6. Administer orderspublic2014-09-25 15:54
Reporterflow4 
PriorityhighSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.7 / 5.0.7 
Target Version4.7.14 / 5.0.14Fixed in Version4.7.14 / 5.0.14 
Summary0005558: Greeting Card with price not listed on billing.pdf -> bill is not correct!
DescriptionIn Oxid CE 4.7.7 greeting cards with price are not listed in billing .pdf or delivery .pdf.
This makes the bill total != single price summ, because greeting card is not listed on the bill
Steps To Reproduce1. Add a product and a greeting Card with price to the basket
2. Proceed through order process
3. login to admin and gernerate billing .pdf -> Total price does not match single product summ, because greeting card is not added
TagsPDF Invoice
ThemeAzure
BrowserAll
PHP Version5.2.1
MySQL Versionany

Activities

flow4

2013-12-06 09:45

reporter  

228_asdasd (1).pdf (570,343 bytes)

flow4

2013-12-06 10:23

reporter   ~0009339

Last edited: 2013-12-06 10:35

View 2 revisions

My Solution:

In myorder.php in protected function _setWrappingInfo

Original: if ( $this->_oData->oxorder__oxwrapcost->value )
Changed To: if ( $this->_oData->oxorder__oxwrapcost->value || $this->_oData->oxorder__oxgiftcardcost->value) {

I did this, because oxwrapcost->value is always 0 if only giftcard is in use

jurate.baseviciene

2013-12-06 14:57

reporter   ~0009341

Reminder sent to: flow4

Hi,

Thank you very much for your bug report. As we saw, you already submitted a complete solution for this issue. If you feel fancy, you'd also have the possibility to contribute your changes directly to our GitHub repository on https://github.com/OXID-eSales/oxideshop_ce/. [^] Please leave a note there with the bug number you fixed so we can close this issue in the bug tracker.

Best regards

aurimas.gladutis

2014-09-25 15:54

reporter   ~0010187

Added suggested fix, fixed few more styling problems regarding greeting card.
Regarding greeting card not listed in delivery note - this is a feature request and new entry was created for it (https://bugs.oxid-esales.com/view.php?id=5891).