View Issue Details

IDProjectCategoryView StatusLast Update
0005556OXID eShop (all versions)1.06. Search, Tagspublic2014-06-11 18:21
ReporterAdrian.Kirchner 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.1 / 5.1.1 
Target Version4.8.7 / 5.1.7Fixed in Version4.9.0_5.2.0_beta1 
Summary0005556: Selected currency gets lost when using search form
DescriptionWhen selecting a non-default currency, oxid depends on the cur parameter in any request (either as GET- or POST parameter).
The search form is the only form (as a short grep shows) which is submitted via GET method.
The action URL looks like this: http://demoshop.oxid-esales.com/professional-edition/index.php?cur=3&
The search form submits additional input fields which instructs the user agent to drop any parameters of the action URL [1]
Steps To Reproduce1) Make sure you have a fresh browser instance without any shop session (or other cookies)
2) Visit the Shop: http://demoshop.oxid-esales.com/professional-edition/
3) Select currency USD
4) Type 'e' in the search form and submit
5) Currency reverted back to EUR
Additional Information[1] http://www.w3.org/TR/html401/interact/forms.html#h-17.13.3.4
TagsCurrency, Search
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Activities

arturas.sevcenko

2014-06-11 18:21

reporter   ~0009955

Fixed with pull request: https://github.com/OXID-eSales/oxideshop_ce/pull/145