View Issue Details

IDProjectCategoryView StatusLast Update
0005537OXID eShop (all versions)2.7. Customer infopublic2014-03-12 15:21
Reportermichael_keiluweit 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.1 / 5.1.1 
Target Version4.7.10 / 5.0.10Fixed in Version4.7.10 / 5.0.10 
Summary0005537: Text in WYSISWG editor from cms sites / article descriptions are empty, when they containing an umlaut
DescriptionWhen the description text contains an umlaut like ä, ö or ü, the shop doesn't display the text in the WYSIWYG editor. But the text is correct in the database. If you save the "empty" page, the shop overwrites the correct text in the database with an empty one ("< p > </ p >").
So its possible, that the shop gives not the text to the editor and therefore the empty page is shown and saved.
The frontend displays the full text everytime.
Steps To ReproduceYou can reproduce it easily in our demoshops: http://demoshop.oxid-esales.com/professional-edition/ . Just try to change the text of the CMS site of the AGBs (general terms and conditions).
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Version5.4
MySQL Versionany

Activities

martinwegele

2013-12-03 11:51

reporter   ~0009327

Last edited: 2013-12-03 11:53

View 4 revisions

Problem is due to a change in PHP5.4: http://www.php.net/manual/de/migration54.incompatible.php#111011
Only shop versions with WysiwygPro running under PHP5.4 (PE 4.7.8 / EE 5.0.8 and higher) in non-utf mode are affected.

Linas Kukulskis

2013-12-03 16:22

reporter   ~0009328

fix: passed encoding to editor and added to htmlspecialchars() function call