View Issue Details

IDProjectCategoryView StatusLast Update
0005536OXID eShop (all versions)2.4. Administer productspublic2013-11-28 17:35
Reporterddpkts 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.1 / 5.1.1 
Target VersionFixed in Version4.8.2 / 5.1.2 
Summary0005536: config bl_perfLoadPrice in article_main
DescriptionIf calculate product price is unchecked in performance settings in admin (bl_perfLoadPrice is false) price calculation crashes (Fatal error: Call to a member function getBruttoPrice() on a non-object in /var/www/.../smarty/df30c6a55a4544194c9cb1ced22db435^%%27^273^27320283%%article_main.tpl.php on line 337) at article_main.tpl on line 236 [{$oPrice->getBruttoPrice()}] because oPrice object is NULL.

This bug is related to https://bugs.oxid-esales.com/view.php?id=4971 - its marked as resolved but I can not see any checks in article_main.php.
Additional InformationSee screenshot attached from official CE demoshop http://demoshop.oxid-esales.com/community-edition/admin/. You will not see error message only because error reporting is turned off. But no html rendering after price input.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0004971 resolvedtadas config bl_perfLoadPrice interfers with admin tpl article_main 

Activities

ddpkts

2013-11-28 14:54

reporter  

Linas Kukulskis

2013-11-28 17:35

reporter   ~0009312

added fix