View Issue Details

IDProjectCategoryView StatusLast Update
0005467OXID eShop (all versions)4.12. Subshop handlingpublic2013-10-23 13:26
Reporterb.hasis 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version4.7.8 / 5.0.8 
Target VersionFixed in Version 
Summary0005467: Produtcs not active in mall can be accessed in the fronend
DescriptionIf You got a Product thats not linked with the Mall, it can be accessed in the Frontend.

Assume you got a Product with url "some.com/product.html" and a Parant Mall also an inherited Mall.

That Product is active in the mall and also in the parent Mall.
The Product will be visible in the frondend of both(list etc.).

Now you remove the heredity for the product to your submall.
What happens is this: in the parent Mall, all the same as befor. Good!
In the submall the products disappear from list etc. Good!
BUT, you can still acces the details page by "some.com/product.html"!

Two things gone wrong here.
1: The URL dont be set to expired.
2: The big problem: There have to be a redirect from "some.com/product.html" to "some.com", this dont happend because in details.php::getProduct() we dont check if this product is even accessible in this mall.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0005424 resolvedaurimas.gladutis Product over the URL is accessible even if product is not assigned to the shop 

Activities

jurate.baseviciene

2013-10-23 13:26

reporter   ~0009189

Hi,

Bug is closed as duplicate of 0005424.

Best regards