View Issue Details

IDProjectCategoryView StatusLast Update
0005465OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2014-09-03 10:03
Reportertomas_liubinas 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.10 / 5.0.10 
Target Version4.7.10 / 5.0.10Fixed in Version4.7.10 / 5.0.10 
Summary0005465: Price rounding precision is hardcoded to 2
DescriptionPrice rounding precision is interpreted as hardcoded 2.

Steps to reproduce:
Set currency rounding precision to 5, switch on "Netto price mode", the prices are displayed rounded to the precision of 2. Eg. 5.36000
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0005580 resolvedLinas Kukulskis decimal precision for currencies is not considered in calculation 
related to 0005420 resolvedLinas Kukulskis VAT calculation not precise enough (rounding differences) in basket 

Activities

Linas Kukulskis

2013-11-05 16:48

reporter   ~0009227

fixed, take configuration from currency object

martinwegele

2014-09-03 09:59

reporter   ~0010124

https://github.com/OXID-eSales/oxideshop_ce/commit/d78151f86b41c0934af79f180a876ce1837767f9

martinwegele

2014-09-03 10:02

reporter   ~0010125

Also fixed in 5.1.1 / 4.8.1 and higher.