View Issue Details

IDProjectCategoryView StatusLast Update
0005461OXID eShop (all versions)2.4. Administer productspublic2014-06-16 14:53
ReporterAlpha-Sys 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version4.7.6 / 5.0.6 
Target Version4.8.7 / 5.1.7Fixed in Version 
Summary0005461: Prices of unassigned articles still exists
DescriptionIf you have a mastershop and some subshops and the articles are administered in the master. Edit the price of an article in a subshop. Switch back to the master shop and unassign the article from this subshop. If you assign the article to the subshop again, the old price from the subshop is still available.
But if you unassign an article the data in the oxfield2shop should be deleted. This works in older Oxid versions.

The function which is responsable for this is the cleanMultishopFields which was changed. In the old version the data for all shops was deleted. In the new version the data is only deleted for the mastershop.

This was the part in the old version:

$sQ = "select oxid from oxshops";
        $rs = $oDb->execute( $sQ );
        while ( $rs && $rs->recordCount() > 0 && !$rs->EOF ) {
         ...
        }

This is missing in the new version.
TagsSubshops
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

martinwegele

2014-03-31 16:03

reporter   ~0009795

Maybe this is a duplicate of 0005474?

jurate.baseviciene

2014-06-16 14:52

reporter   ~0009964

Hi,

Unable to reproduce from version 5.1.5, bug is fixed with other changes.

Best regards