View Issue Details

IDProjectCategoryView StatusLast Update
0005460OXID eShop (all versions)4.07. Source code, Testpublic2014-02-20 17:51
Reportermartinwegele 
PrioritylowSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.6 / 5.0.6 
Target Version4.8.5 / 5.1.5Fixed in Version4.9.0_5.2.0_beta1 
Summary0005460: wrong description of constructor for all list models
DescriptionI think somebody did copy&paste of this comment because it does not fit to what the method does:
 /**
     * Class constructor, sets callback so that Shopowner is able to
     * add any information to the article.
     *
     * @param string $sObjectsInListName Object in list
     */
    public function __construct( $sObjectsInListName = 'oxdeliveryset')
    {
        $this->setHomeCountry( $this->getConfig()->getConfigParam( 'aHomeCountry' ) );
        parent::__construct( 'oxdeliveryset' );
    }

This can be found in seven files of application/models.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

tadas

2014-02-20 17:51

reporter   ~0009560

Removed unused optional parameter $sObjectsInListName and changed comments several methods.