View Issue Details

IDProjectCategoryView StatusLast Update
0005459OXID eShop (all versions)1.04. Content, static (register, contact etc.) pagespublic2014-03-06 12:42
Reportermartinwegele 
PrioritylowSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version4.7.8 / 5.0.8 
Target Version4.8.5 / 5.1.5Fixed in Version4.9.0_5.2.0_beta1 
Summary0005459: wrong help link in oxViewConfig::getHelpLink()
DescriptionThere is a method oxViewConfig::getHelpLink() which returns something like index.php?cl=help. But there is no help.php in application/controllers.
Therefore we see the following error message in the Exception-Log very frequently:
oxSystemComponentException-oxException (time: 2013-10-05 05:48:09): [0]: EXCEPTION_SYSTEMCOMPONENT_CLASSNOTFOUND
 Stack Trace: [removed]
 Faulty component --> help

The method is called in oxViewConfig::getHelpPageLink() which is used in the footer: application/views/azure/tpl/widget/footer/services.tpl
Usually that link works but sometimes it does not (I could not reproduce that yet). Please investigate if the method getHelpLink is needed any more or if it can be removed.
Additional InformationThe help controller was removed in 4.5.0 so I guess that this bug was present ever since.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005588 resolvedLinas Kukulskis Method getHelpLink() is obsolete in oxviewconfig?! 

Activities

martinwegele

2014-01-02 14:41

reporter   ~0009373

Maybe this is helpful?
http://wiki.oxidforge.org/Tutorials#Creating_new_help_page_from_OXID_eShop_4.4.0_on

tadas

2014-03-06 12:42

reporter   ~0009612

Last edited: 2014-03-07 12:34

View 3 revisions

Removed old method oxviewconfig::getHelpLink(), which should have been deprecated since 4.5.0, and reference to it.