View Issue Details

IDProjectCategoryView StatusLast Update
0005440OXID eShop (all versions)1.03. Basket, checkout processpublic2013-10-07 10:04
Reportervanilla thunder 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.7.8 / 5.0.8 
Target VersionFixed in Version 
Summary0005440: basket update resets selection list values and prices
Descriptionselected values of selections lists are getting lost during basket update.
Steps To Reproduce

  1. enable "Support Price Modifications by Selection Lists" (for more drama)

  2. create new selection list and couple of values with price surcharge

  3. assign dat selection list to an article

  4. go to article details page and add every selection list variant to the basket

  5. go to basket page and check the prices

  6. press "update" and enjoy

TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0004240 resolvedaurimas.gladutis Selectionlist selection is deleted in basket on Update 

Activities

leofonic

2013-09-26 23:32

reporter   ~0009117

this is fixed in beta 480: https://bugs.oxid-esales.com/view.php?id=4240

cesnauskast

2013-10-07 10:04

administrator   ~0009129

Hi, as this does require template changes, we will release it only in 5.1. For earlier versions please use this fix:
change azure/tpl/page/checkout/inc/basketcontents.tpl line 84 to:

                            [{if !$basketitem->isBundle() || !$basketitem->isDiscountArticle()}]
                                [{assign var="oSelections" value=$basketproduct->getSelections(null,$basketitem->getSelList())}]
                                [{if $oSelections}]
                                    <div class="selectorsBox clear" id="cartItemSelections_[{$smarty.foreach.basketContents.iteration}]">
                                    [{foreach from=$oSelections item=oList name=selections}]
                                        [{if $oViewConf->showSelectListsInList()}]
                                            [{include file="widget/product/selectbox.tpl" oSelectionList=$oList sFieldName="aproducts[`$basketindex`][sel]" iKey=$smarty.foreach.selections.index blHideDefault=true sSelType="seldrop"}]
                                        [{else}]
                                            [{assign var="oActiveSelection" value=$oList->getActiveSelection()}]
                                            [{if $oActiveSelection}]
                                                <input type="hidden" name="aproducts[[{$basketindex}]][sel][[{$smarty.foreach.selections.index}]]" value="[{if $oActiveSelection }][{$oActiveSelection->getValue()}][{/if}]">
                                                <div>[{$oList->getLabel()}]: [{$oActiveSelection->getName()}]</div>
                                            [{/if}]
                                        [{/if}]
                                    [{/foreach}]
                                    </div>
                                [{/if}]
                            [{/if }]


This bug is closed as duplicate of 0004240

Best regards,
Tomas