View Issue Details

IDProjectCategoryView StatusLast Update
0005439OXID eShop (all versions)1.09. Integrations: Facebook, Trusted Shops, Shop lupe, Econdapublic2013-10-07 12:43
Reportervanilla thunder 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version4.7.8 / 5.0.8 
Target Version4.7.9 / 5.0.9Fixed in Version 
Summary0005439: facebook social buttons trying to load even without an fb app id
Descriptionfacebook social buttons on product details page loads even if app id is not configured.

application/views/azure/tpl/page/details/inc/productmain.tpl row 326
[{if ( $oView->isActive('FbShare') || $oView->isActive('FbLike') && $oViewConf->getFbAppId() ) }]

which actually results a wrong condition for loading buttons:
if ( share plugin is active ) OR ( like plugin active + app id is set )
so it would load buttons when you enable the share plugin in backend.
the simpliest solution would be to move the last braket before the && condition
[{if ( $oView->isActive('FbShare') || $oView->isActive('FbLike') ) && $oViewConf->getFbAppId() }]
Steps To Reproduce

  1. empty app id and secret key

  2. enable share and disable all other facebook plugins

  3. go to a product details page

  4. console output will be like "error: oxFacebook is not defined"

Additional Informationin my opinion, share should work even without an app id, cause sharing is like copying site url directly into the status box of facebook: it doesnt care if the page has an app id or not.
But facebook init widget loads only if the facebook app id is configured.
TagsFacebook
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0005358 acknowledged If FB Share is enabled, Share widget appears without App ID 

Activities

leofonic

2013-10-07 11:34

reporter   ~0009132

duplicate of https://bugs.oxid-esales.com/view.php?id=5358

jurate.baseviciene

2013-10-07 12:43

reporter   ~0009133

Hi,

The issue is closed as duplicate of 0005439

Best regards