View Issue Details

IDProjectCategoryView StatusLast Update
0005399OXID eShop (all versions)1.03. Basket, checkout processpublic2014-04-15 15:04
Reporterhenrik.steffen 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGooglebotOSGooglebotOS VersionGooglebot
Product Version4.7.7 / 5.0.7 
Target Version4.9.0_5.2.0_beta1Fixed in Version4.8.5 / 5.1.5 
Summary0005399: EXCEPTION_SYSTEMCOMPONENT_TEMPLATENOTFOUND, Faulty component --> content.tpl
DescriptionThis exception can sometimes be found in EXCEPTION_LOG

The reason is, that the template path to "content.tpl" is missing in $_sThisAltTemplate in basket.php

In render() method there is this if-block:

if ( oxUtils::getInstance()->isSearchEngine() ) {
   return $this->_sThisTemplate = $this->_sThisAltTemplate;
}

So, set your user-agent to for instance "googlebot" and get the Exception and a white screen in the shop frontend when accessing

http://demoshop.oxid-esales.com/community-edition/warenkorb/



Steps To Reproducesee above
TagsNo tags attached.
ThemeAll
BrowserAll
PHP Versionany
MySQL Versionany

Activities

aurimas.gladutis

2014-03-28 14:00

reporter   ~0009782

Removed this $_sThisAltTemplate at all and default template is loaded for search engines with noFollow meta tag, as this was used with basic theme and for azure it does not fit anymore.