View Issue Details

IDProjectCategoryView StatusLast Update
0005396OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2015-10-05 12:15
Reportereike_spriess 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version4.7.7 / 5.0.7 
Target Version4.7.8 / 5.0.8Fixed in Version 
Summary0005396: Payment Method -> Price Surcharge/Reduction - VAT is not calculated right
Descriptionsee screenshot attached.

Correct calculation is:

Sum articles 100 EUR
Discount -10 EUR
Price Surcharge -10 EUR

VAT 12,77 EUR in Shop we calculate 14,37 EUR (19% from 90 EUR)
SUM 80,00 EUR
TagsCalculations, Payment, Price Calculation, VAT
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0004712 resolvedLinas Kukulskis No discount in the order 
related to 0005405 acknowledged Basket Payment Method VAT not shown on negative paymethod surcharges 

Activities

eike_spriess

2013-09-06 14:25

developer  

Zahlart.JPG (40,533 bytes)
Zahlart.JPG (40,533 bytes)

martinwegele

2013-09-12 12:04

reporter   ~0009075

Last edited: 2013-09-12 13:02

View 5 revisions

One of our biggest partners called and told us that the current behaviour of the shop regarding the displaying of VAT in this case is correct because this is the VAT for the articles only!
Therefore I will close this issue as "no change required".
However there is a related bug 0005405 concerning the calculation of (negative) surcharge for a payment method. A possible fix is described there.