View Issue Details

IDProjectCategoryView StatusLast Update
0005351OXID eShop (all versions)4.07. Source code, Testpublic2014-02-20 13:35
Reportermarco_steinhaeuser 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.6 / 5.0.6 
Target Version4.8.5 / 5.1.5Fixed in Version4.9.0_5.2.0_beta1 
Summary0005351: OXID eShop CE checks for Zend Platform/Server
DescriptionThere seems to be code in OXID CE in /core/oxsysrequirements.php checking for Zend Platform/Server that is only used in EE:

public function checkZendPlatformOrServer()
{
if (function_exists( 'output_cache_get' )) {
return 2;
}
if (function_exists( 'zend_disk_cache_fetch' )) {
return 2;
}
if (function_exists( 'zend_shm_cache_fetch' )) {
return 2;
}
return 1;
}

This code shall not be delivered in CE.
Additional Informationfound it here:
http://forum.oxid-esales.com/showthread.php?t=20224

Didn't look into the code myself yet.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

There are no notes attached to this issue.