View Issue Details

IDProjectCategoryView StatusLast Update
0005347OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2014-03-04 11:28
Reporteritsabug 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version4.7.6 / 5.0.6 
Target VersionFixed in Version 
Summary0005347: isForBasketItem not returning boolean when checking for category discount
DescriptionAccording to oxid documentation oxBasketItem::isForBasketItem returns a boolean value.
This is not true when the method checks for category based discounts.

When $blOk = $this->_checkForArticleCategories( $oArticle ); is triggered (Line 175), $blOk is assigned with a return value from an getOne statement. In this case $blOk holds either an oxid or theoretically NULL.

This can lead to faulty discount calculations when you check for isForBasketItem() === true.
Steps To ReproduceTrigger $this->_checkForArticleCategories( $oArticle ); and check the return value.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

jurate.baseviciene

2013-10-04 14:36

reporter   ~0009126

Reminder sent to: itsabug

Hi,

Thanks a lot for submitting this issue, but unfortunately we can not reproduce this issue. If there still is a problem, maybe you could send us more details about it? Because if we try to reproduce this case then isForBasketItem is returning bool when checking for category discount, never return value NULL.


Best regards