View Issue Details

IDProjectCategoryView StatusLast Update
0005321OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2015-04-15 16:00
Reportertomas_liubinas 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version4.7.7 / 5.0.7 
Summary0005321: Loading of articles is not performed in other subshops
DescriptionArticles are not loaded from any other subshop except the active one.

Steps To ReproduceCreate the second empty shop on the demo shop. Try to execute the following code when active shop is the empty one:

$oArt = oxNew("oxarticle");
$oArt->load('09651d283fce7bcb313debfad743121f');

The product is not loaded.
Additional InformationThe problem is that product data is loaded from db view.


So the quick fix (for the hotfix) would be enabling the core table usage in oxArticle::_loadFromDb() method:
$this->_blForceCoreTableUsage = true;

(and restoring it back to the previously set value)
in the same way as it's done in oxBase::load() method.

The correct fix:
Replace $this->_loadFromDb() usage with the parent::load() usage in oxArticle::load() method as the intention of these methods are completely the same.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005424 resolvedaurimas.gladutis Product over the URL is accessible even if product is not assigned to the shop 
related to 0004409 resolvedtomas_liubinas Session sharing between subshops with different domains does not work 

Activities

Linas Kukulskis

2013-08-06 16:04

reporter   ~0008946

added view with language usage.