View Issue Details

IDProjectCategoryView StatusLast Update
0005320OXID eShop (all versions)2.3. Extensions (modules, themes)public2013-08-14 10:10
Reporterarvydas_vapsva 
PriorityimmediateSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version4.7.6 / 5.0.6 
Target Version4.7.6 / 5.0.6Fixed in Version 
Summary0005320: Problems with modules
DescriptionConfiguration:
- Master shop, no modules are active, has no dedicated domain, shop is not used
- Subshop 1, ~ 20 modules are active, runs on shop1.com
- Subshop 2, ~ 20 modules are active, runs on shop2.com
- Subshop 3, ~ 20 modules are active, runs on shop3.com
- subshop 4, ~ 22 modules are active, runs on shop4.com

Sometimes after clicking through any of subshops you get redirected to start page and exception is written in exception log.

After activating ALL modules in master shop, this problem disappear.

So seems like for some reason at least modules configuration data sometimes is loaded from master shop.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005047 resolvedLinas Kukulskis APC cache brake oxNew modules class chain 
related to 0005356 resolvedLinas Kukulskis APC + modules 

Activities

arvydas_vapsva

2013-08-14 09:31

reporter   ~0008952

Last edited: 2013-08-14 09:32

View 2 revisions

Problem is not in oxid, but in server configuration. So in case you have similar issues, please check if your server is not running APC. In our case configuration looks like:
- PHP Version 5.3.13-pl0-gentoo
- Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies
- APC Support enabled

We disabled APC via .htaccess:
php_flag apc.cache_by_default Off

And the problem is gone!

Linas Kukulskis

2013-08-14 10:10

reporter   ~0008953

duplicates with related