View Issue Details

IDProjectCategoryView StatusLast Update
0005310OXID eShop (all versions)1.05. Userspublic2014-04-15 10:25
Reportermartinwegele 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1.0 revision 17976 
Target VersionFixed in Version4.8.5 / 5.1.5 
Summary0005310: superfluous if statement in Newsletter::removeme()
DescriptionNewsletter::removeme() removes the user only from the newsletter group if the setting for double opt in (blOrderOptInEmail) is not active. There are other places (e.g. Account_Newsletter::subscribe) where a cancellation of the newsletter is possible but there no check for this setting is done and the user is removed from the group.
According to Linas's code review the if statement in Newsletter::remove is not needed and can be removed.
Additional InformationProbably this has been like that forever, at least since version 4.1.0.
TagsNo tags attached.
ThemeAll
BrowserAll
PHP Versionany
MySQL Versionany

Activities

saulius.stasiukaitis

2014-03-31 14:26

reporter   ~0009794

Account_Newsletter::subscribe works correct. It allow subscription to newsletter for logged and not logged user. It always allow unsubscribe, but subscription depends on configuration. blOrderOptInEmail requires confirmation from email.

Newsletter::removeme allow user unsubscribe from newsletter. Data in table oxobject2group do not change if blOrderOptInEmail is checked and unsubscribe from newsletter link.