View Issue Details

IDProjectCategoryView StatusLast Update
0005299OXID eShop (all versions)1.05. Userspublic2015-05-04 15:34
Reportertaniol 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.6 / 5.0.6 
Target Version4.8.5 / 5.1.5Fixed in Version4.8.5 / 5.1.5 
Summary0005299: Dynamic group assignment after register doesn't work anymore
DescriptionIn oxcmp_user::createUser following statement is called (line 503):
$oUser->addDynGroup( oxSession::getVar( 'dgr' ), $myConfig->getConfigParam( 'aDeniedDynGroups' ) );

at this point, the session variable "dgr" doesn't exist because it wasn't set before. I've made a module for oxcmp_user and changed the method oxcmp_user::registerUser as follow:

public function registerUser()
{
    // sets missing dgr var in session
    oxRegistry::getSession()->setVariable("dgr", oxRegistry::getConfig()->getRequestParameter("dgr"));
    return parent::registerUser();
}
Steps To ReproduceMake use of the "dgr" parameter with an oxid of a new usergroup which is not a denied group, e.g. as hidden field in the register template.
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Activities

aurimas.gladutis

2014-03-31 12:58

reporter   ~0009792

Moved to init method, as this method is always loaded before any action.