View Issue Details

IDProjectCategoryView StatusLast Update
0005206OXID eShop (all versions)2.6. Administer orderspublic2013-06-20 08:51
Reportermarcharding 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformLinuxOSDebianOS Version7.1
Product Version4.7.5 / 5.0.5 
Target VersionFixed in Version 
Summary0005206: Product price is recalculated in order view, but should be left untouched
DescriptionThe price of products in an order is recalculated when you set the payment-date or any other field in the admin order view.

This is an major issue when you change the price of a product shortly after it was ordered.

If you process the order afterwards (set the payment or shipping-date etc.), the product price in the order gets recalculated and now differs from the price the customer received in his order-confirmation mail.
Steps To Reproduce1. Place an order
2. Change the price of any product included in that order
3. Process order (e.g. set payment-date)
4. Price of the product in that order has changed
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0004624 acknowledged Order recalculation does not use discounts/taxes which were valid when order was made, but current ones 
has duplicate 0005734 acknowledged Cancelling one orderitem updates prices of all other 

Activities

ray

2013-06-19 16:10

reporter   ~0008797

dublicate: https://bugs.oxid-esales.com/view.php?id=4624

jurate.baseviciene

2013-06-20 08:50

reporter   ~0008803

Hi,

We actually know this problem. So this case is closed as duplicate of 0004624.

Best regards