View Issue Details

IDProjectCategoryView StatusLast Update
0005162OXID eShop (all versions)1.03. Basket, checkout processpublic2015-10-05 12:15
Reportereike_spriess 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.5 / 5.0.5 
Target Version4.7.10 / 5.0.10Fixed in Version4.7.10 / 5.0.10 
Summary0005162: Coupon calculation is not correkt, when articles are assigned and
DescriptionDiscount will be calculated to each product per cart position, but should be calculated only once, if option ""Calculate only once"" is set.
Steps To Reproduce1. Create a Coupon (like attached) with X articles assigned in coupon.
2. In Frontend select 2,3 or 4 of the X articles. The discount should be calculated once, because "Calculate only once" is activated in the coupon.
3. Discount calculation is wrong. Should be calculated only once, not per cart position.
Additional InformationIf no article is assigned to coupon serie, the calculation works fine.
TagsCalculations, Price Calculation, Voucher
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0002454 resolvedLinas Kukulskis Calculate only once (valid only for product or category vouchers) --> Help is missing 
has duplicate 0005841 closed oxvoucher__oxcalculateonec still allows multiple calculations 
related to 0006063 acknowledgedflorian.auer Coupon Series: discount only on first article in basket if coupon is assigned on selected articles 
related to 0002242 resolveddainius.bigelis wrong voucher discount 

Activities

eike_spriess

2013-06-12 11:59

developer  

coupon_1.JPG (49,486 bytes)
coupon_1.JPG (49,486 bytes)

martinwegele

2013-06-14 09:12

reporter   ~0008772

If I remember correctly this is an intended behaviour. In the described scenario the shop will calculate the discount only once if you add the same product multiple times to the cart/ basket. However if you intend to have a number of products for which the discount should be applied only once just add them to a hidden category and apply the coupon to this category.

martinwegele

2013-08-16 12:27

reporter   ~0008959

Please compare Dainius's comment: https://bugs.oxid-esales.com/view.php?id=2242#c3785

dmitrijus.druteika

2013-09-20 13:10

manager   ~0009105

This bug priority should be higher, because it is related to money loss for merchants!
In some cases, customers get discounts many times higher, that coupon provides.

Linas Kukulskis

2013-11-07 13:10

reporter   ~0009248

fixed with a contribution

martinwegele

2014-04-07 14:28

reporter   ~0009814

https://github.com/druteika/oxideshop_ce/commit/28f750ef3f5b2192be5ccf854781ff580382280b