View Issue Details

IDProjectCategoryView StatusLast Update
0005077OXID eShop (all versions)2.3. Extensions (modules, themes)public2013-04-29 17:03
Reporterray 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version4.7.4 / 5.0.4 revision 57063 
Target VersionFixed in Version 
Summary0005077: module shows deactivated if extending one class with are an array ov several files
DescriptionIf extending one class with several files, it works when using an array like this:

'extend' => array(
                  'shopclass' => array('path/to/my/file_1',
                                       'path/to/my/file_2',
                                       'path/to/my/file_3')
                       ),

or this:

'extend' => array(
                  'shopclass' => 'path/to/my/file_1'
                                 .'&path/to/my/file_2'
                                 .'&path/to/my/file_3'
                       ),


But in the modules list this module does not show "active" - even though it is, and all three extensions work.
Additional InformationThere is an "workaround-module" from Shoptimax extending oxmodule which resolves this behaviour. File attached.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0004424 resolvedmantas.vaitkunas There should be possibility to extend same class more than one time in one module. 

Activities

ray

2013-04-18 14:18

reporter  

smx_oxmodule.zip (6,313 bytes)

tadas

2013-04-19 16:12

reporter   ~0008635

Thank you very much for reporting the issue. However, this functionality is not supported in shop, and we don't see why it would be necessary. If you could elaborate on the matter, what you are trying to achieve, or why this exact implementation is required, it might be worthwhile to add the functionality for it in future releases.

Currently, if you want to extend same class several times, you can do so in a single file.

ray

2013-04-21 12:52

reporter   ~0008636

Actually this functionality exists, extending one class with several files in an array is working. The only problem is, that this module is not shown as "active" in modules list.

Certain cases make it necessary to extend the same class with several files within the same module. For example to avoid dublicate code and keep the shop lean and slim.