View Issue Details

IDProjectCategoryView StatusLast Update
0005071OXID eShop (all versions)2.4. Administer productspublic2013-05-06 08:19
Reporterfinnegan 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.3 / 5.0.3 revision 54408 
Target Version4.7.5 / 5.0.5Fixed in Version4.7.6 / 5.0.6 
Summary0005071: EE: save article in subshop is not possible if oxprice is excluded from aMultishopArticleFields
DescriptionIf in EE you have an article in the master shop and make certain fields editable in a subshop the "save" button is greyed out if oxprice is not included in the aMultishopArticleFields array in config.inc.php.

In our case we do _not_ want to make oxprice editable in a subshop but we want to edit short and long desc. So I edited aMultishopArticleFields to include only those fields we want to have editable in a subshop. After that the save button in article_main is greyed out.

The reason seems to be the test in the template article_main:

[{if $readonly && (!$edit->canUpdateField('oxprice') || $edit->isParentNotBuyable())}][{$readonly}][{/if}]

So if I exclude oxprice from aMultishopArticleFields canUpdateField returns false and the button is greyed out.
Additional InformationFurthermore I have to check "Allow individual prices for derived articles" in the subshop config even if I do _not_ want individual prices in subshops. Otherwise function "public function canUpdateField( $sField )" will always return false which will set even those fields to readonly that I _do_ want to have editable in subshops (e.g. short desc).
Maybe the checkbox description in shop config should be more clear about that.
TagsProducts, Subshops
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

tadas

2013-05-06 08:19

reporter   ~0008667

Made a change so that if there is a field that can be edited, save button is active and working.