View Issue Details

IDProjectCategoryView StatusLast Update
0005067OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2014-03-10 16:19
ReporterSouleater 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.4 / 5.0.4 revision 57063 
Target Version4.8.5 / 5.1.5Fixed in Version4.9.0_5.2.0_beta1 
Summary0005067: Error with hidden categories and navigation
Description1) mark all categories as hidden in admin which are shown below "More" in frontend -> it still shows "More" in navigation bar

2) only categories with articles shown below "More", categories with articles in subcategories are not shown

3) is it intended to show all categories when clicking on "More"? In a 4.6.3 it shows only those which aren´t in the main navigation bar

4) if you create a hidden but activated category and try to access it in frontend, an error (page does not exist) occurs. You need to go to SEO-tab in admin first, then the access in frontend is possible
TagsCategory
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

Souleater

2013-04-12 17:59

reporter  

fehler1.jpg (151,622 bytes)
fehler1.jpg (151,622 bytes)

Souleater

2013-04-12 17:59

reporter  

fehler2.jpg (114,830 bytes)
fehler2.jpg (114,830 bytes)

ray

2013-04-13 19:06

reporter   ~0008602

translation:

1) mark all categories as hidden in admin which are shown below "More" in frontend -> it still shows "More" in navigation bar

2) only categories with articles shown below "More", categories with articles in subcategories are not shown

3) is it intended to show all categories when clicking on "More"? In a 4.6.3 it shows only those which aren´t in the main navigation bar

4) if you create a hidden but activated category and try to access it in frontend, an error (page does not exist) occurs. You need to go to SEO-tab in admin first, then the access in frontend is possible

jurate.baseviciene

2013-04-17 13:35

reporter   ~0008621

Reminder sent to: Souleater

Hi,

Thanks a lot for submitting this issue, but we can't reproduce such issue on version 5.0.4. Could you please try to reproduce that on our demo shops:
http://demoshop.oxid-esales.com/community-edition/
http://demoshop.oxid-esales.com/professional-edition/
?

Best regards

ray

2013-04-17 13:48

reporter   ~0008622

actually (as you can see at the screenshots) this was tested in demoshop

Souleater

2013-04-17 18:06

reporter   ~0008627

great, you send me an email from no-reply because of this? tried to reply.

well, as ray already wrote, it is only in 4.7.4

don't know why you mention 5.0.4 (EE)

the problem might be only in all CE and PE versions

and yes, I used the demoshops (they are both 4.7.4 - the same sourcecodes)

ray

2013-04-18 10:10

reporter   ~0008628

the email is only a notification about the new status / comment - it is not intended to answer to the email but add information here in the bugtracker

EE 5.0 corresponds with PE/EE 4.7 and sourcecode is (nearly) equal

Linas Kukulskis

2014-03-10 16:19

reporter   ~0009632

1. fixed
2. not able reproduce
3. its page for all categories
4. not able reproduce