View Issue Details

IDProjectCategoryView StatusLast Update
0005047OXID eShop (all versions)2.3. Extensions (modules, themes)public2013-09-05 13:59
ReporterLinas Kukulskis 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionduplicate 
Product Version4.7.3 / 5.0.3 revision 54408 
Target Version4.7.8 / 5.0.8Fixed in Version4.7.8 / 5.0.8 
Summary0005047: APC cache brake oxNew modules class chain
Descriptionon new module setup; on php with apc cache on, module chain is broken, because of cached old chain;


TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005320 resolvedLinas Kukulskis Problems with modules 
related to 0005356 resolvedLinas Kukulskis APC + modules 

Activities

Linas Kukulskis

2013-04-05 17:23

reporter   ~0008568

after changes in module apc cache must be flushed;
additinal info:
http://www.php.net/manual/en/function.apc-clear-cache.php

mark

2013-04-09 11:14

reporter   ~0008575

Hi,

did you test shops with different module chains in subshops? We had big problems and therefore launched without apc - no big difference in performance.

best regards,
Mark

Linas Kukulskis

2013-04-09 11:52

reporter   ~0008576

hi, Mark

if you had problems or think that this is a bug, please add it as separate bug or call to our support.

design3000

2013-04-10 11:45

reporter   ~0008590

Hi!

It is not enough to clear the apc cache.
If you have a lot of modules there are used in many subshops, the problem occurs again and again /-;

The problem can occur if, for example, you start an external export scripts that includes the oxid-framework (bootstrap process).

I recommend to exclude the modules folder by the apc.ini file (apc.filters="-modules/.*$") as long as the issue isn's resolved.
Details: http://www.php.net/manual/de/apc.configuration.php#ini.apc.filters

mark

2013-05-27 11:28

reporter   ~0008723

@design3000 we tested to exclude the modules dir too, but had no luck until yet (different modules in different subshops)

design3000

2013-05-27 14:45

reporter   ~0008724

hi mark,
create a file with the following content

print_r(apc_cache_info());

open this file in a browser and search for 'oxid-directory/modules' to check whether the apc settings are set correctly.

the array should not contain cached php fils in the modules directory else you have to check your settings (-: