View Issue Details

IDProjectCategoryView StatusLast Update
0005031OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2014-02-10 10:05
Reporterdesign3000 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.3 / 5.0.3 revision 54408 
Target VersionFixed in Version4.7.10 / 5.0.10 
Summary0005031: Function 'getVendorTree' is missing
DescriptionHi,

it is not possible to view/open details page from vendor list.

>> Function 'getVendorTree' does not exist or is not accessible! (details)

The method/function was forgotten in the oxubase.php or should no longer be used?
Steps To Reproduce1) Open: http://demoshop.oxid-esales.com/community-edition/Nach-Lieferant/www-true-fashion-com/

2) Click on an Article to view Details.
TagsNo tags attached.
ThemeBoth
Browserother
PHP Versionany
MySQL Versionany

Activities

design3000

2013-04-02 10:34

reporter   ~0008545

Oops! The SEO link to reproduce the bug don't work.
Try: http://demoshop.oxid-esales.com/community-edition/?cl=vendorlist&cnid=a57c56e3ba710eafb2225e98f058d989

michael_keiluweit

2013-06-18 11:27

developer   ~0008780

Because this is affecting the SEO URL it is bad if a customer has a high ranking with it but the link in the shop is broken.

EggSupport

2013-07-02 15:19

reporter   ~0008867

maybe a workaround
edit /application/controllers/oxubase.php, and add these lines maybe before last '}'


/** vendortree patch */

    public function getVendorTree()
    {
        return $this->_oVendorTree;
    }

    public function setVendorTree( $oVendorTree )
    {
        $this->_oVendorTree = $oVendorTree;
    }

Linas Kukulskis

2013-11-15 13:07

reporter   ~0009271

fixed removed usage of this method