View Issue Details

IDProjectCategoryView StatusLast Update
0005017OXID eShop (all versions)2.4. Administer productspublic2015-05-04 15:21
Reporterfinnegan 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformLinuxOSCentOSOS Version6.0
Product Version4.7.3 / 5.0.3 revision 54408 
Target VersionFixed in Version 
Summary0005017: Wysiwig Editor does not work in SSL mode
DescriptionWhen using Admin with https the wysiwig editor does not work due to wrong paths.

Error is in file oxadmindetails

$sEditorUrl = $myConfig->getConfigParam( 'sShopURL' )./*$myConfig->getConfigParam( 'sAdminDir' ).*/"core/{$sEditorPath}/";
if ( $sAdminSSLURL = $myConfig->getConfigParam( 'sAdminSSLURL' ) ) {
   $sEditorUrl = "{$sAdminSSLURL}/{$sEditorPath}/";
}

Suspected reason: code was not properly updated when moving wysiwig from /admin to /core
So in SSL $sAdminSSLURL contains "https://mydomain.de/admin//wysiwigpro" instead of "https://mydomain.de/core/wysiwigpro"

Steps To Reproduceconfig.inc.php

set
$this->sSSLShopURL = 'https://mydomain.de'; // eShop SSL url, optional
        $this->sAdminSSLURL = 'https://mydomain.de/admin'; // eShop Admin SSL url, optional

Try to edit long desc of ec. a category
Check requested files by firebug (e.g. .../editor.css)
See wrong URL
TagsHTTPS, WYSIWYG
ThemeBoth
BrowserAll
PHP Version5.3
MySQL Versionany

Relationships

duplicate of 0004989 resolvedtadas WYSIWYGPRO broken if Admin in SSL-Mode 

Activities

jurate.baseviciene

2013-03-25 07:03

reporter   ~0008529

Last edited: 2013-03-25 07:03

View 2 revisions

Closed as duplicate of 0004989