View Issue Details

IDProjectCategoryView StatusLast Update
0005013OXID eShop (all versions)3.2. HTML, CSS, JavaScriptpublic2013-03-22 16:11
Reporter[email protected] 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.3 / 5.0.3 revision 54408 
Target VersionFixed in Version4.8.0_5.1.0_beta1 
Summary0005013: Cloud Zoom doesnt load data-zoomparams into rel attribute when triggered through AJAX
DescriptionThe Cloud Zoom Plugin doesnt load the parameters given by the data-zoomparams attribute into the rel when the Variant is changed => default Cloudzoom is loaded.

Workaround: add [{oxscript add="$('#zoom1').attr( 'rel', $('#zoom1').attr('data-zoomparams'));"}] into /views/page/details/ajax/productmain.tpl /views/page/details/ajax/fullproductinfo.tpl
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Activities

mantas.vaitkunas

2013-03-22 10:56

administrator   ~0008524

Reminder sent to: [email protected]

Hello,
We checked Your report, but we were unable to reproduce the problem. Could you describe the problem in more detail?

[email protected]

2013-03-22 11:06

reporter   ~0008525

Hello,

I was modifing a template and I used the data-zoomparams to change the position and size of the Cloud Zoom Popup. First it worked fine but when I selected a variant, the position of the cloudzoom Image was back at default. I noticed that you put via Javascript everything which is in data-zoomparams into rel (because thats where the cloudzoom plugin gets its options).
So you do this by [{oxscript add="$('#zoom1').attr( 'rel', $('#zoom1').attr('data-zoomparams'));"}] (page/details/prodctmain.tpl line 42). But this is missing in page/details/ajax/productmain.tpl and page/details/ajax/fullproductinfo.tpl).

Hope I could help

mantas.vaitkunas

2013-03-22 16:11

administrator   ~0008528

Fixed. Javascript was overlapping.