View Issue Details

IDProjectCategoryView StatusLast Update
0004976OXID eShop (all versions)1.09. Integrations: Facebook, Trusted Shops, Shop lupe, Econdapublic2013-05-24 16:15
Reportermark 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.3 / 5.0.3 revision 54408 
Target VersionFixed in Version4.7.6 / 5.0.6 
Summary0004976: Wrong Trusted Shops protection prices in config array
DescriptionIndex: oxtsprotection.php
===================================================================
--- oxtsprotection.php (Revision 1587)
+++ oxtsprotection.php (Arbeitskopie)
@@ -32,7 +32,7 @@
      *
      * @var array
      */
- protected $_sTsCurrencyProducts = array( "TS080501_500_30_EUR" => array( "GBP" => "TS100629_500_30_GBP", "CHF" => "TS100629_1500_30_GBP", "USD" => "TS080501_500_30_USD" ),
+ protected $_sTsCurrencyProducts = array( "TS080501_500_30_EUR" => array( "GBP" => "TS100629_500_30_GBP", "CHF" => "TS100629_500_30_CHF", "USD" => "TS080501_500_30_USD" ),
                                        "TS080501_1500_30_EUR" => array( "GBP" => "TS100629_1500_30_GBP", "CHF" => "TS100629_1500_30_CHF", "USD" => "TS100629_1500_30_USD" ),
                                        "TS080501_2500_30_EUR" => array( "GBP" => "TS100629_2500_30_GBP", "CHF" => "TS100629_2500_30_CHF", "USD" => "TS100629_2500_30_USD" ),
                                        "TS080501_5000_30_EUR" => array( "GBP" => "TS100629_5000_30_GBP", "CHF" => "TS100629_5000_30_CHF", "USD" => "TS100629_5000_30_USD" ),
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

Linas Kukulskis

2013-03-06 09:19

reporter   ~0008474

Reminder sent to: mark

hi, please give more details which prices are wrong?

mark

2013-03-06 10:19

reporter   ~0008475

this is original code:
protected $_sTsCurrencyProducts = array( "TS080501_500_30_EUR" => array( "GBP" => "TS100629_500_30_GBP", "CHF" => "TS100629_1500_30_GBP", "USD" => "TS080501_500_30_USD" ),

this is corrected:
protected $_sTsCurrencyProducts = array( "TS080501_500_30_EUR" => array( "GBP" => "TS100629_500_30_GBP", "CHF" => "TS100629_500_30_CHF", "USD" => "TS080501_500_30_USD" ),

i changed value for CHF from TS100629_1500_30_GBP to TS100629_500_30_CHF since key of this array is TS080501_500_30_EUR and defines TS protected for prices up to 500 EUR/CHF/GBP/USD

mark

2013-03-06 10:19

reporter   ~0008476

btw bug is confirmed by trusted shops

Linas Kukulskis

2013-03-06 10:42

reporter   ~0008477

fixed

Linas Kukulskis

2013-05-22 18:29

reporter   ~0008712

bad fix

mark

2013-05-22 18:35

reporter   ~0008713

solved it via github

Linas Kukulskis

2013-05-24 16:15

reporter   ~0008720

fixed with contribution