View Issue Details

IDProjectCategoryView StatusLast Update
0004901OXID eShop (all versions)2. ----- eShop backend (admin) -----public2013-02-06 10:47
Reporterleofonic 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.3 / 5.0.3 revision 54408 
Target VersionFixed in Version4.7.4 / 5.0.4 revision 57063 
Summary0004901: bin/cron.php shows "Fatal error: Cannot redeclare isadmin()"
Descriptioncron.php declares function isAdmin and then includes core/oxfunctions.php which also declares function isAdmin.

Additionally, if this is fixed, cron.php crashes apache (xampp windows), probably because config file is not defined. Why not use bootstrap.php?

<?php
include "../bootstrap.php";
oxNew( "oxmaintenance" )->execute();
oxRegistry::getConfig()->pageClose();

executes without error.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

Linas Kukulskis

2013-02-06 10:47

reporter   ~0008376

added bootstrap.php