View Issue Details

IDProjectCategoryView StatusLast Update
0004882OXID eShop (all versions)4.07. Source code, Testpublic2013-04-09 13:17
Reporterkarmaedv 
PriorityhighSeverityblockReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Product Version4.7.3 / 5.0.3 revision 54408 
Target VersionFixed in Version 
Summary0004882: Invalid argument supplied for foreach() after clean installation on https
DescriptionJust did a clean install on a new DB without demo data on a https site. Then switched to frontend which results in blank error screen and this is the error I am getting.


Warning: Invalid argument supplied for foreach() in /home/casemods/public_html/kedv/shop/core/oxlist.php on line 436

Warning: Invalid argument supplied for foreach() in /home/casemods/public_html/kedv/shop/core/oxlist.php on line 436

Warning: Cannot modify header information - headers already sent by (output started at /home/casemods/public_html/kedv/shop/core/oxlist.php:436) in /home/casemods/public_html/kedv/shop/core/oxutils.php on line 1068

Warning: Cannot modify header information - headers already sent by (output started at /home/casemods/public_html/kedv/shop/core/oxlist.php:436) in /home/casemods/public_html/kedv/shop/core/oxutils.php on line 1069

Warning: Cannot modify header information - headers already sent by (output started at /home/casemods/public_html/kedv/shop/core/oxlist.php:436) in /home/casemods/public_html/kedv/shop/core/oxutils.php on line 1070
Steps To ReproduceFresh install on fresh DB without demo data. (Maybe https is also important)

Additional InformationInternet Explorer 10
PHP 5.4
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Version5.4
MySQL Versionany

Activities

aurimas.gladutis

2013-02-01 09:27

reporter   ~0008360

Hi, sorry but we could not reproduce this case. Have you checked if database was created successfully? Maybe you could provide some more details on this case? What MySQL version and which exact php version was used (5.4.9 e.g.)?

aurimas.gladutis

2013-02-01 13:31

reporter   ~0008362

Reminder sent to: karmaedv

Hi, sorry but we could not reproduce this case. Have you checked if database was created successfully? Maybe you could provide some more details on this case? What MySQL version and which exact php version was used (5.4.9 e.g.)?

karmaedv

2013-02-01 19:57

reporter   ~0008367

Hi, following versions from my hoster:

MySQL
    Server: Localhost via UNIX socket
    Server Version: 5.1.65-cll
    Protokoll-Version: 10
    Benutzer: c///////@localhost
    MySQL-Zeichensatz: UTF-8 Unicode (utf8)

Webserver

    cpsrvd 11.32.5.13
    MySQL-Client-Version: 4.1.22
    PHP Erweiterung: mysql Dokumentation

PHP version 5.4.9

I was able to install the shop with demo data without problems.
Have you tried with HTTPS?

Linas Kukulskis

2013-04-09 13:17

reporter   ~0008580

unable to reproduce