View Issue Details

IDProjectCategoryView StatusLast Update
0004847OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2014-03-24 15:49
Reporterpatchwork.de 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.2 revision 46646 
Target Version4.8.5 / 5.1.5Fixed in Version4.9.0_5.2.0_beta1 
Summary0004847: duplicated title / description tags in product detail page concerned by Google webmaster tools
Descriptiona product detail page can be called from different sites eg manufacturer and categories. In all cases we get a different URI but same title and description!
Steps To Reproducelook in demo shop a product eg from manufacturer list and category list (see screenshots)
Additional Informationbecause this is concerned in Google webmaster tools there should be an urgend patch! This can be avoided by adding the category / manufacturer name in title and description
TagsCategory, Manufacturer, Promotion
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005527 resolvedtomas.lygutas Pagehead on Details Page ist not working properly, if the Article has variants. 

Activities

patchwork.de

2013-01-13 10:09

reporter  

screenshots.jpg (132,840 bytes)
screenshots.jpg (132,840 bytes)

patchwork.de

2013-01-13 10:24

reporter   ~0008250

I fixed it in my test shop by editing oxubase and details.php.
See example:
http://www.patchwork.de/shop/Patchworkzubehoer/MicroStitch/Avery-Dennison-Avery-Micro-Stitch-Heftpistole-Starterkit.html

and

http://www.patchwork.de/shop/Patchworkzubehoer/Kleber-Fixierer/Avery-Dennison-Avery-Micro-Stitch-Heftpistole-Starterkit.html

martinwegele

2014-03-21 15:03

reporter   ~0009674

Since the shop sets the rel="canonical" link element correctly this should actually not be a problem: https://support.google.com/webmasters/answer/66359?hl=en
https://support.google.com/webmasters/answer/139066

Linas Kukulskis

2014-03-24 15:49

reporter   ~0009680

added new method oxUbass::getPageTitle(); this method can be extended for shop owner needs. also fixed all page title, removed logic from templates.